Problem:


One of my channel orders is displaying the wrong SKU in Linnworks. Channel Mapping screen for the respective channel shows the SKU I expect to display on the order.


Example:

My Channel SKU is 00120090but on the order, I see Linnworks SKU Cat205.


I check Settings > Channel Integrations > Mapping for the order Source integration and SKU 00120090 appears to be linked to 00120090 there correctly.



Cause:


Order item linking does not depend solely on the Channel Mapping screen linking. Although Channel Mapping linking is how to make sure you Channel SKUs are connected to the correct inventory items, then it is actually another part of the system that Linnworks looks at to determine what to display on the order.


If the linking import has been done incorrectly or any updates have not been done fully when changing the linking or the SKUs on the channel directly, then one Channel SKU can be mistakenly linked to several Linnworks SKUs. The Channel Mapping screen will only be able to display one of them. Order linking process does not know which one to choose if they have the same Channel SKU, Source and SubSource, so it will take a random one from all available options that are linked. These available links are all displayed in the Product Details of the item in the Channel SKU tab.


Channel SKU tab is used as a priority for order item linking because there are also cases where you want items to be linked on orders, but there is no official channel for them e.g. when importing orders. Please see this article for how the setup should be done for imported orders.


Solution:


If you are seeing an incorrect SKU on the order, search for that "wrong" SKU in your My Inventory > open Product Details > Channel SKU tab > and check that there would not be any incorrect links added for that SKU for the Source and Subsource the order is from.


If you see any links that should not be there, can either delete them from the tab manually or by using the Delete Stock Item Linking import.


Example:

I check my "wrong" SKU Cat205 and see that in Channel SKU tab it does indeed have an incorrect linking to Channel SKU 00120090 so I delete the link.


If you suspect that you may have other incorrect links like that in your system, you can use the following steps to identify and delete them in bulk:


  1. Dashboards > Query Data > Query type: Channel SKUs.
    NB! This report will only give you the linking per Source, so for each Source, you will need to pull a separate report. The produced CSV  will include all of your My Inventory items and show whether and which Channel SKUs from that Source are linked to it.

  2. Filter the produced CSV to exclude empty Channel SKU fields i.e. if there is no link for the Channel for that Linnworks SKU.

  3. Check that all remaining results are indeed linkings you expect to be there.

  4. In case of any incorrect linkings, mark them down in a separate CSV which you can later use for a Delete Stock Item Linking import to eliminate any wrong entries in one go. Steps and an example file for this import are given in the documentation link.