Note: This is a channel-specific article only applicable to the Shopify, Walmart, and Cdiscount channels.


Problem

When Linnworks updates an order to mark it as shipped, the incorrect courier can be added to the order instead of the courier defined in the Vendor field of the Linnworks Postal Service Method.


Cause

When updating an order as shipped and sending tracking URLs, Linnworks uses the following logic: 

  • Linnworks attempts to match the courier from the Linnworks Postal Services > Vendor to our internal list of couriers that support tracking URLs. A full list of couriers is below.
  • The order must contain a tracking number.


If one of the above conditions fails, the channel (Shopify, Walmart, or Cdiscount) will use internal logic to assign another courier (vendor).  


Solution

List of shipping couriers that currently support tracking URLs:

  • Amazon Shipping
  • APC Overnight
  • Aramex
  • Asendia
  • Auspost Corp
  • Caribou
  • Collect Group
  • Deutsche Post
  • DHL
  • DHL Parcel UK
  • DHL US Direct
  • DPD
  • DPD DE
  • DPD FR
  • DPD France
  • DPD IE
  • DPD Ireland
  • DPD Local
  • DPD UK
  • DX
  • DX Freight
  • Endicia
  • ETrak
  • EVRi
  • Express Freight
  • FedEx
  • FIMS
  • Freipost
  • GFS
  • GLS
  • GLS US
  • Hermes Corporate
  • InPost
  • Interlink
  • Landmark
  • Landmark Global
  • MyHermes
  • OCS Worldwide
  • OnTrac
  • Packeta
  • Parcel2Go
  • Parcelforce
  • Raben
  • Royal Mail
  • Royal Mail Tracked
  • SmartConsign
  • SmartConsign 2020
  • Spring
  • Spring Omni
  • Stamps.com
  • TNT
  • Trakpak
  • UK Mail
  • UPS
  • Whistl
  • wnDirect
  • Xpressbees
  • Yodel


To check if a correct vendor is specified in Linnworks:

1. Go to Linnworks.net > Shipping > Postal Services.
2. Check the Vendor column:
3. Edit vendor name to one from the list if required.

To check if a Shipping Service is linked to an actual Shipping Integration:

  1. Go to Linnworks.net > Shipping > Postal Services.
  2. Check the Integrated with Vendor column.
  3. Clicking on the View Links button lets you see through which Shipping Integration this Shipping Service is linked.

You can also check if this Shipping Service is properly linked in the Shipping Integration itself: 

  1. Go to Shipping > Interactions
  2. Find the needed Shipping Integration and click the Services button.
  3. Check if the link is active:


To check if a shipping label has been printed for an order:

  1. Open the order's audit trail
  2. See if there is a note about the shipping label being printed.