Problem
The despatch notification from Magento does not contain a tracking number.
Cause
The reason for this is that Magento requires a shipment to be created and then the tracking information to be added to it. However, it is at the point of creating the shipment that Magento sends the despatch notification, meaning that the tracking number will not be available.
Solution
The Magento Way
Magento requires you to click the button Send Tracking Info from your admin page. This will send another email containing the tracking information, but it is a manual solution and will result in the customer receiving duplicate emails.
The Linnworks Way
Deselect the option to send a Magento despatch notification and use the Linnworks email notifications instead. Create a Linnworks dispatch notification email and give it a condition of [{Source}]="MAGENTO"
For more information on how to set up an email template: http://www.linnworks.com/support/emails/email-notifications