When Linnworks updates an order on Amazon to mark it shipped, it always sets the carrier on Amazon to Standard instead of the carrier name defined in the Vendor field of the Linnworks Postal Service Method.
Cause
Amazon has a list of fixed Carrier codes that are used to update the Carrier for the order through the API. If the Vendor name used does not match one of the predefined codes then the carrier will be set to Standard.
Solution
Change the Vendor for the appropriate Linnworks Postal Service in the Postal Services screen to match the value required by Amazon.
See below for the list of available carriers and the Linnworks Vendor name to be used.
Currently supported codes from Amazon:
4PX
AFL/Fedex
Amazon Shipping
Aramex
AUSSIE_POST
Australia Post
AustraliaPost-ArticleId
AustraliaPost-Consignment
Blue Package
BlueDart
BRT
Canada Post
China Post
Chrono Express
Chronopost
City Link
Correios
Correos
Delhivery
Deutsche Post
DHL
DHL Global Mail
DPD
DTDC
Endopack
EUB
Fastway
Fastway
FedEx
FedEx SmartPost
FEDEX_JP
First Flight
GLS
GO!
Hermes Logistik Gruppe
India Post
JP_EXPRESS
La Poste
Lasership
MRW
Nacex
Newgistics
NipponExpress
NITTSU
OnTrac
OSM
Other
Otro
Overnite Express
Parcelforce
Parcelnet
Poste Italiane
Professional
Royal Mail
SAGAWA
SagawaExpress
SDA
Seur
SF Express
Smartmail
Streamlite
Target
TNT
Toll Global Express
UPS
UPS Mail Innovations
UPSMI
USPS
YAMATO
YamatoTransport
YANWEN
Yodel
Yun Express