Please note this is a channel-specific article only applicable to Amazon.


Problem



Amazon Inventory Sync is returning the error message:

Start sync Error: Amazon SubmitInventoryChange: Feed Rejected


Cause


a) The API authorization for Linnworks has expired.


b) Amazon is rejecting the feed before even looking at it. This suggests that Amazon has put some sort of restriction or limitation on the account.


Any restrictions should be accessible in Amazon Seller Central, if not please contact Amazon directly for more details

If the account has restrictions or has been suspended, Linnworks is still able to download orders, but it is not allowed to change stock levels.



Solution


a) Go to Settings -> Channel Integrations -> Amazon -> Edit channel details -> TestIf the popup displays the following error:

Access to Reports.GetReportRequestList is denied then follow this solution article to resolve the matter. 


If the channel test is successful, see solution b.


b) Contact Amazon to confirm there are no restrictions on the account.


If the account is suspended or has a restriction, you need to switch off the inventory sync for the specific channel so that it will not interfere with the other integrated Amazon accounts.


If there are no restrictions, then further investigation is required by the Linnworks team to confirm - please contact our technical support team.