Problem

Amazon Inventory Sync is returning the message Start sync Error: Amazon SubmitInventoryChange: Feed Rejected


Cause

Amazon are rejecting the feed before even looking at it; this suggests that Amazon have put some sort of restriction or limitation on the account account.

Any restrictions should be accessible in Amazon Seller Central, if not please contact Amazon directly for more details

If the account has restrictions or has been suspended, Linnworks is still able to download orders, but it is not allowed to change stock levels. 


Solution
Contact Amazon to confirm there are no restrictions on the account.


If the account is suspended or has restriction, you need to switch off the inventory sync for the specific channel so that it will not interfere with the other integrated Amazon accounts


If there are no restrictions, then further investigation is required by the Linnworks team to confirm - please contact our technical support team.