Linnworks Virtual Printer Issues

Hi there, 

We are having multiple issues with Virtual Printer service. Today whenever we try to log on or print something it just crashes virtual printer and gives error 110207 on

For the last few weeks we also get issues with some sort of server socket and we have to disconnect and log on again to be able to print. 

Anyone able to help with this or had similar issues?


Please try to uninstall Virtual Printer from your computer and then install it again. You might be using outdated version of Virtual Printer that is causing this issue. 

This is a version of Virtual Printer that should definitely work:

Best regards,

I have downloaded the latest copy from Linnworks directly, it still gives us major issues, we have to keep disconnecting then logging in again.

This is getting silly now, we can't do 2 prints in a row without having to do this. I've also tried taking out the printer then installing it again, reinstalled virtual printer and tried it on a different computer. 

There is something wrong with virtual printer and I dont know what it is. 


Do you get any errors before you need to disconnect the software and log in again? Is it the same as you used to get before or a new one? If so, may we please have a screen shot?

Possibly, your firewall or antivirus are blocking the connection to our Virtual Printer server so it may be worth checking this bit.

thank you in advance.

Best regards,

Ilja Lissov

Technical Support Service

TCP Callback failed with error:

 System.Net.Sockets.SocketException (0x80004005): A connect request was made on an already connected socket

   at System.Net.Sockets.Socket.EndConnect(IAsyncResult asyncResult)

   at System.Net.Sockets.TcpClient.EndConnect(IAsyncResult asyncResult)

   at LinnPrint.Controller.TcpComponent.<CallBack>d__3.MoveNext()

I am now having this error, I use McAffee total protection, please can anyone help with this?


Hi there, 

Still no response to this? can anyone help please?


Are you still receiving the same error?

Have you tried disabling firewall and your McAffee anti-virus to see if the issue persists? If not, I would suggest doing so, you may need to create exceptions for your firewall and anti-virus.

Kind regards,


Yes we are still experiencing issues, I have tried disabling firewall and antivirus and still the issues occur.

Login to post a comment