WooCommerce integration throws an error "Error: Missing parameter data"

I am using woocommerce Version 2.6.7

Linnworks is able to download orders from Woocommerce but fail to post anything back to WooCommerce e.g. Order Completion notification or inventory update.

When I try to test the connection using channel integration module (as well as in the jobs failure logs), the see the following message:

"Error: Missing parameter data"

I remember very well that it used to work about 2 months ago. Just to make sure that its not my setup of woocommerce, i trid a clean installation of wordpress and woocommerce and still have the same issue. Hence, i believe the issue lies with Linnworks

Please help.


1 person has this problem

Hello there,

Just wanted to let you know that we are looking into the issue you have described. 

Could you please clarify, have you tried to reintegrate Woocommerce after testing the integration? 

Kind regards,


Hi, I have tried to reintegrate the linnworks and same problem persists. After entering the brand new set of keys, the system throws the same error.

Just to ensure that this is not an issue with my woocommerce, I setup a brand new woocommerce on a new dummy website and linnworks throws the same error. Hence, I am very much sure, its something to do with linnworks.

hope this helps.



any update please?

Same problem here


Hi John,

Sounds like I am not the only one. But unfortunately, no one at linnworks is replying to this issue.


I sincerely apologise for keeping you waiting.

There are a couple of thing worth checking. First of all, you need to make sure the Consumer Key and Consumer Secret Key are set to Read/Write as per our documentation (see point 6 of Detailed Guide):


Also, please check if you have a plugin installed on the Wordpress instance called "ithemes security". It might be blocking all put and post requests.

Hope this helps.

Kind regards,


Hi Alex

Thanks for reverting back.

Well, I am afraid, keys are set as read/write mode. I double checked by creating a new pair of keys too.

also ithemes security is not installed.

As I said, i created a brand new woocommerce installation with NO plugin and integration failed there as well.


any update please?

Hello Sanyam,

 I've responded to the new topic that you created.

With Best Regards,


Linnworks Technical Support

Login to post a comment