Magento Invalid XML Error

Since Linnworks support is refusing to help with the issue (just told to use the inferior .net platform) I'm putting this out for the public.

We use the desktop client (as it is quicker and easier to use than the .net platform on so many levels).

We operate a Magento website which was populated via LinnLive desktop. The site was originally non-ssl as we were still developing the site and it was not "Live". However, on changing the site to SSL we now get an error when trying to list that simply states "Invalid XML" therefore we are unable to proceed with listing more products on the site.

Support have told us just to use the .net tool - which works, however, the workflow is slower and more "Clumsy" than the desktop version of LinnLive.

Does anyone have any ideas on how to fix the "Invalid XML" error and allow us to continue populating the site via the desktop client?


Does your Magento site forward all http traffic to https? Desktop is probably making a http request out and not getting the response it expects

Yes all the traffic is forwarded to HTTPS

Hello Dan,

I have just done exactly the same, only difference is this was on a live site rather than a development site.

I've just submitted a ticket with LinnWorks so I'm guessing I will receive the same response.

Like you I much prefer the desktop version and would be very keen to get this resolved for the same reasons.

Out of interest how did you go about re-directing the site, did you simply change the Base URL from http to https and change the other unsecure sections to secure?

This worked for me but then my urls on google was redirecting to the home page rather then the https equivalent so have some research found I needed to add the following to our .htacces file:

## enable rewrites

    Options +FollowSymLinks

RewriteEngine On

RewriteCond %{HTTPS} off

RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

RewriteCond %{HTTPS} on

RewriteCond %{HTTP_HOST} !^www\.(.*)$ [NC]

RewriteRule ^(.*)$ https://www.%{HTTP_HOST}/$1 [R=301,L]

This sorted google but I'm wondering if I need something extra so that LinnLive can work, I'm guessing the LinnLive extension is trying to load a page in http rather than https and is being given the home page rather then the url it is requesting but I have no idea what the url is as the error message I am receiving from LinnLive is very basic.

I'll keep on researching this issue on the forums and if I find a solution I'll let you know, like wise if you get this resolved please let me know.

Kindest Regards


Hello again Dan,

I've made some progress I have added the following line to our .htaccess file and I'm no longer receiving the invalid XML error message, however I'm still unable to create listings as I'm now receiving another error.

## uncomment next line to enable light API calls processing


 RewriteRule ^api/([a-z][0-9a-z_]+)/?$ api.php?type=$1 [QSA,L]

Having spoken to Klaas Schippers from Linnworks the issue is now resolved for us we are back up and listing- it seems to be something internal to Linnworks beyond our control so might be worth you (Chris) raising a ticket with them.

Login to post a comment