e bay token expired, tried this and it doesn't work

From linnworks support pages

This error means that your eBay authentication token is in valid or cannot validate.

Causes and Solutions

1. Your authentication token has expired, this is generally caused by either change in account details (password, business name, address, etc), the other is a time expire, eBay do this for security reasons.

The solution to fixing this issue is to go to Settings -> Channel Integration > click Config next to the eBay account

Click TestThe system will prompt you that it cannot authenticate the account,Answer yes to ResubscriptionGo through the authorization form again

This will renew your authentication token. 

2. eBay's authentication service is not responding/unavailable.

If this is the case then you will need to contact eBay to rectify the issue.

I get the following error

Class Error

System.ComponentModel.Win32Exception: Class not registered

   at System.Diagnostics.Process.StartWithShellExecuteEx(ProcessStartInfo startInfo)

   at System.Diagnostics.Process.Start(ProcessStartInfo startInfo)

   at eBay.Service.Util.SdkUtility.LaunchSignInPage(ApiContext Context, String SessionID)

   at linnworks.automation.ebay.frmeBayConfig.btnTest_Click(Object sender, EventArgs e)

   at System.Windows.Forms.Control.OnClick(EventArgs e)

   at Telerik.WinControls.RadControl.OnClick(EventArgs e)

   at Telerik.WinControls.UI.RadButton.ButtonElement_Click(Object sender, EventArgs e)

   at Telerik.WinControls.RadItem.OnClick(EventArgs e)

   at Telerik.WinControls.UI.RadButtonItem.OnClick(EventArgs e)

Hello there,

May I ask at what point exactly do you receive an error message?

 I've tried launching the process from my end, however due to the fact that we do not have direct access to your eBay we cannot finish the procedure. Please do NOT post the credentials here as this is a public forum. Instead if you are receiving the above mentioned issue in the process of resetting your token then the issue might be in one of your files in Linnworks folder. Simply try re-installing it and see if that helps. 

I had this problem the other day, so I'm guessing its one of the Linnworks.net 'enhancements' that did it.   I presume by now you have managed to get this fixed?

To fix it we have to go to the Channel Integrations page and edit the eBay channel, click test and follow the on screen prompts to regenerate a token.. The fix and prompt does not appear in linnworks.net

Login to post a comment