When installing the LinnLive Extension on Magento, it returns the following error: Package community/LinnLiveConnect 1.1.65: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.0.10-2+deb.sury.org~trusty+1
We have tested the extension with PHP7 version on our end and it does not work with Magento 1. We have also confirmed that PHP7 officially is only supported by Magento 2. Magento documentation also indicates that the system requirements for Magento 1 are PHP 5.4.x or PHP 5.5.x.
You can have a look at this article which describes the resources and support for PHP7 on Magento 2.
There are also unofficial compatibility patches available online for Magento 1 and PHP7. But please keep in mind that these were not tested by us and we cannot provide any support for them.