Please note that this is a channel-specific article only applicable to Amazon.


Problem

Inventory updates sent to Amazon are not reflected correctly in the Amazon inventory screen.



Possible cause


There are several Amazon integrations in the system with the same MerchantID and different MarketplaceIDs and the SKUs on these different marketplaces (under the same unified account) are the same. 


For example, I can have a unified Amazon account for UK, DE, and FR. They are integrated under the same MerchantID, because they are linked to the same account, but the MarketplaceIDs are different - so I could download all orders from all marketplaces and update inventory for these marketplaces separately.


Since it is the same unified Amazon account - same Merchant ID but different Marketplace IDs - and the SKUs match for these different marketplaces, Amazon interprets the inventory information as valid for all channels/marketplaces when Linnworks sends it. So Amazon sets the inventory information to be the same on each marketplace as a default behavior on their end.


Here is an excerpt from the Amazon Marketplace Web Service Feeds API Section Reference:


Quantity is a global value in relationship with a SKU, so changes to stock levels are reflected in all marketplaces that the SKU is active in. If multiple inventory feeds are processed for the same SKU in different marketplaces, then the quantity of the last uploaded inventory feed from the seller reflects the global inventory level. Setting the item inventory level to 0 effectively sets the item quantity to 0 in all marketplaces and makes the item non-buyable. All listing information is still maintained in the system.



To illustrate this issue, let us take a look at the following example:


A seller has one merchant account on Amazon and sells on three different marketplaces – UK, DE, FR.


There are three integrations in Linnworks – all with the same Merchant ID, but with different Marketplace IDs: one for UK, one for DE, one for FR.


During inventory synchronization, Linnworks syncs these channels independently and in that same order - UK > DE > FR. 


Let us assume that the available quantity to be sent to Amazon is 10 for UK, 20 for DE, and 30 for FR - because of the different location mapping for these channels. The channel SKUs are absolutely identical.


Since Linnworks sends stock level updates for the same SKU for all three different marketplaces in the order specified above, it will send a the quantity of 30 last (for the FR marketplace). Amazon will update all quantities on all marketplaces for this channel SKU to 30, as per this last submission - see Amazon's explanation above.



Solution


In order to resolve this problem and have the same Linnworks SKU maintain different stock levels on different marketplaces, the seller needs to make sure that the SKUs on Amazon are different. For example, SKU123 in Linnworks would be linked to SKU123_UK on the UK marketplace, SKU123_DE on the DE marketplace, and SKU123_FR on the FR marketplace. All these channel SKUs can be easily linked to the same Linnworks SKU123 for these three different channels via the inventory mapping screen and when Linnworks submits the stock update to the channel, Amazon will interpret them as different SKUs and will not update other marketplaces, because the SKUs on them do not match.