Please note this is a channel-specific article only applicable to Shopify.


Problem


The Process POS orders setting is enabled, but stock is not deducted in Linnworks.



Possible cause


1. Check on your Shopify back-end whether the setting Mark Orders as Fulfilled is enabled.

2. Check whether the Linnworks setting Download processed orders in Settings > Channel Integrations > Edit channel details is enabled.


If both of these settings are enabled at the same time, as soon as the sale is made via Shopify POS, that order is marked processed on Shopify. The order then gets downloaded into Linnworks because the Download processed orders setting applies, but since it is downloaded as already processed, the stock levels in Linnworks are not deducted.



Solution


To resolve this, disable the setting Mark Orders as Fulfilled in your Shopify backend. This ensures the correct settings are applied i.e. the POS order is downloaded into Linnworks as an open order and then automatically processed within Linnworks, deducting the stock levels correctly as well.